Hvad skal man gøre, når et WordPress-plugin går ned

Gå ikke i panik!

Så dit websted indlæses ikke, og du ser nogle forvirrende fejlmeddelelser som denne...

forældet: Påkrævet parameter $ids følger valgfri parameter $table in /you/wp-content/plugins/user-login-history/inc/common/helpers/class-db.php på linje 113

Advarsel: Kan ikke ændre header-oplysninger – headers er allerede sendt af (output startet på you/wp-content/plugins/user-login-history/inc/common/helpers/class-db.php:113) i /dig/wp-includes/pluggable.php på linje 1083

Den slags sker meget med de nyeste versioner af PHP 8. Et stødende plugin eller tema får dit WordPress-websted til at gå ned, fordi det ikke er opdateret. For at rette dette skal du stoppe det fra at indlæse med WordPress.

Brug FTP eller din hostingudbyders filhåndtering til at finde det plugin, der er beskrevet i fejlen. Når du har fundet det, skal du omdøbe plugin-mappen ved at tilføje et enkelt tegn til slutningen af ​​navnet, såsom en understregning. Sådan her…

you/wp-content/plugins/user-login-history

you/wp-content/plugins/user-login-history_

Opdater nu din WordPress-side, og den skulle indlæses uden fejl.

Hvis du går til WordPress Plugin-siden, vil det klage over, at plugin ikke kan indlæses. Det er godt. Du kan arbejde på problemet og omdøbe det tilbage, eller slette det og installere en ny kopi. At vende tilbage til PHP 7.4 ofte vil løse problemet.

Efterlad en kommentar

Dette websted bruger Akismet til at reducere spam. Lær, hvordan dine kommentardata behandles.