Cosa fare quando un plugin di WordPress si arresta in modo anomalo

Non Panic!

Quindi il tuo sito non verrà caricato e visualizzi alcuni messaggi di errore confusi come questo...

deprecato: il parametro obbligatorio $ids segue il parametro opzionale $table in /tu/wp-content/plugins/user-login-history/inc/common/helpers/class-db.php on line 113

avvertimento: Impossibile modificare le informazioni sull'intestazione: le intestazioni sono già state inviate da (l'output è iniziato su you/wp-content/plugins/user-login-history/inc/common/helpers/class-db.php:113) in /tu/wp-includes/pluggable.php on line 1083

Questo genere di cose sta accadendo spesso con le ultime versioni di PHP 8. Un plugin o un tema offensivo sta causando il crash del tuo sito WordPress perché non è aggiornato. Per risolvere questo problema, è necessario interromperne il caricamento con WordPress.

Usa FTP o il file manager del tuo provider di hosting per trovare il plug-in descritto nell'errore. Una volta individuato, rinomina la cartella del plug-in aggiungendo un singolo carattere alla fine del nome, ad esempio un trattino basso. Come questo…

you/wp-content/plugins/user-login-history

you/wp-content/plugins/user-login-history_

Ora aggiorna la tua pagina WordPress e dovrebbe caricarsi senza errori.

Se vai alla pagina Plugin di WordPress, ti lamenterà che il plugin non può essere caricato. Questo è buono. Puoi lavorare sul problema e rinominarlo di nuovo, oppure eliminarlo e installarne una nuova copia. Il ripristino di PHP 7.4 spesso risolverà il problema.

Lascia un tuo commento

Questo sito utilizza Akismet per ridurre lo spam. Scopri come vengono elaborati i dati dei tuoi commenti.