Wat te doen als een WordPress-plug-in crasht

Geen paniek!

Uw site wordt dus niet geladen en u ziet enkele verwarrende foutmeldingen zoals deze...

Verouderd: Vereiste parameter $ids volgt optionele parameter $table in /you/wp-content/plugins/user-login-history/inc/common/helpers/class-db.php online 113

waarschuwing: Kan header-informatie niet wijzigen - headers die al zijn verzonden door (uitvoer gestart bij you/wp-content/plugins/user-login-history/inc/common/helpers/class-db.php:113) in /u/wp-includes/pluggable.php online 1083

Dit soort dingen gebeurt veel met de nieuwste versies van PHP 8. Een aanstootgevende plug-in of thema zorgt ervoor dat uw WordPress-site crasht omdat deze niet up-to-date is. Om dit op te lossen, moet u voorkomen dat het wordt geladen met WordPress.

Gebruik FTP of de bestandsbeheerder van uw hostingprovider om de plug-in te vinden die in de fout wordt beschreven. Zodra je het hebt gevonden, hernoem je de map van de plug-in door een enkel teken toe te voegen aan het einde van de naam, zoals een onderstrepingsteken. Soortgelijk…

jij/wp-content/plugins/user-login-history

jij/wp-content/plugins/user-login-history_

Ververs nu uw WordPress-pagina en deze zou zonder fouten moeten laden.

Als u naar de WordPress Plugin-pagina gaat, zal deze klagen dat de plug-in niet kan worden geladen. Dit is goed. U kunt aan het probleem werken en het terug hernoemen, of het verwijderen en een nieuwe kopie installeren. Terugkeren naar PHP 7.4 lost het probleem vaak op.

Laat een bericht achter

Deze site gebruikt Akismet om spam te verminderen. Ontdek hoe uw reactiegegevens worden verwerkt.