Ce să faci când un plugin WordPress se blochează

Nu te panica!

Deci site-ul dvs. nu se va încărca și vedeți câteva mesaje de eroare confuze ca acesta...

Deprecated: Parametrul necesar $ids urmează parametrul opțional $table în /you/wp-content/plugins/user-login-history/inc/common/helpers/class-db.php on-line 113

avertizare: Nu se pot modifica informațiile din antet – anteturile deja trimise de (ieșirea a început la you/wp-content/plugins/user-login-history/inc/common/helpers/class-db.php:113) în /tu/wp-includes/pluggable.php on-line 1083

Acest gen de lucruri se întâmplă foarte des cu cele mai recente versiuni de PHP 8. Un plugin sau o temă ofensătoare provoacă blocarea site-ului dvs. WordPress deoarece nu este actualizat. Pentru a remedia acest lucru, trebuie să opriți încărcarea cu WordPress.

Utilizați FTP sau managerul de fișiere al furnizorului dvs. de găzduire pentru a găsi pluginul descris în eroare. Odată ce îl localizați, redenumiți folderul pluginului adăugând un singur caracter la sfârșitul numelui, cum ar fi un caracter de subliniere. Ca aceasta…

tu/wp-content/plugins/user-login-history

tu/wp-content/plugins/user-login-history_

Acum reîmprospătează-ți pagina WordPress și ar trebui să se încarce fără erori.

Dacă accesați pagina WordPress Plugin, se va plânge că pluginul nu poate fi încărcat. Este bun. Puteți să lucrați la problemă și să o redenumiți sau să o ștergeți și să instalați o copie nouă. Revenirea la PHP 7.4 deseori va rezolva problema.

Lăsați un comentariu

Acest site folosește Akismet pentru a reduce spamul. Aflați cum sunt procesate datele despre comentarii.