WordPress插件崩溃时该怎么办

不要惊慌!

因此,您的网站将无法加载,并且您会看到一些令人困惑的错误消息,例如……

已过时: 必需参数 $ids 跟在可选参数 $table 之后 /you/wp-content/plugins/user-login-history/inc/common/helpers/class-db.php 上线 113

警告:无法修改标头信息 - 标头已由(输出开始于 you/wp-content/plugins/user-login-history/inc/common/helpers/class-db.php:113)在 /美味/wp-includes/pluggable.php 上线 1083

这种事情在最新版本的 PHP 8 中经常发生。一个有问题的插件或主题导致您的 WordPress 网站崩溃,因为它不是最新的。 要解决此问题,您需要阻止它使用 WordPress 加载。

使用 FTP 或您的托管服务提供商的文件管理器查找错误中描述的插件。 找到它后,通过在名称末尾添加一个字符(例如下划线)来重命名插件的文件夹。 像这样…

你/wp-content/plugins/user-login-history

你/wp-content/plugins/user-login-history_

现在刷新您的 WordPress 页面,它应该可以正常加载。

如果你去 WordPress 插件页面,它会抱怨无法加载插件。 这很好。 您可以处理该问题并将其重命名,或将其删除并安装新副本。 恢复到 PHP 7.4 通常会解决这个问题。

发表评论

本网站使用Akismet来减少垃圾邮件。 了解您的数据如何处理.